ITGoran blog

.NET, MEF, ASP .NET MVC, IoC, PowerShell, WCF, CSLA

By

The system cannot find the file specified – The server encountered an unexpected error and stopped. (FIM 2010) – solved.

When I was installing SharePoint 2010 i encounter an error from the title.
Log in EventLog was:

The server encountered an unexpected error and stopped.
“ERR: MMS(4828): libutils.cpp(10475): RegQueryValueEx of Server failed with 2
BAIL: MMS(4828): libutils.cpp(10477): 0x80070002 (The system cannot find the file specified.)
ERR: MMS(4828): libutils.cpp(10475): RegQueryValueEx of SQLInstance failed with 2
BAIL: MMS(4828): libutils.cpp(10477): 0x80070002 (The system cannot find the file specified.)
ERR: MMS(4828): libutils.cpp(10475): RegQueryValueEx of DBName failed with 2
BAIL: MMS(4828): libutils.cpp(10477): 0x80070002 (The system cannot find the file specified.)
BAIL: MMS(4828): server.cpp(281): 0x80070002 (The system cannot find the file specified.)
BAIL: MMS(4828): server.cpp(3518): 0x80070002 (The system cannot find the file specified.)
BAIL: MMS(4828): service.cpp(1528): 0x80070002 (The system cannot find the file specified.)

I spend hours trying to figure out what file missing. Well, solutions was quite different.

I added service account (account for window services Forefront Identity Manager Service and Forefront Identity Manger Synchronization Service)
into three groups on local machine:
FIMSyncOperator, FIMSyncJoiners and FIMSyncBrowse and errors gone.

Strange was also that when I installed SharePoint 2010, service account was /.

I change this to domain user account and that user added into three groups mention previously.

Hope that this will save you time.

9 Responses to The system cannot find the file specified – The server encountered an unexpected error and stopped. (FIM 2010) – solved.

  1. Mike Ray says:

    Hello:
    I’m having the same problem on a Win 2008 box with SP 2010 instaled… I was exctied to find your blog, however the FIM security groups you mention do not EXIST on my server. Any suggestions would be appreciated.
    Thanks,
    Mike

  2. Darryl Lang says:

    I ran into the same issue as Mike Ray and have not found a resolution for it yet either. I created the local groups, but of course they don’t fix it since there are no extra permissions assigned to them.

  3. Darryl Lang says:

    and figures I’d find an answer same day …
    Ran through this: http://blogs.msdn.com/opal/archive/2009/11/16/installation-notice-for-sharepoint-2010-public-beta.aspx
    and this: http://www.sharepointdevwiki.com/display/spadmin2010/15+-+Configure+User+Profile+Synchronization+Service

    and it started working sometime during all that… I actually noticed the services started immediately after I configured the Delegate Control in AD.

  4. Shelter says:

    I’m having the same problem on virtual machine (vmware) with Win 2008 and SP 2010.

    There are no groups FIMSyncOperator, FIMSyncJoiners and FIMSyncBrowse after install SP 2010 (standalone installation). But then i go to services on server, click User profile service – start, I see account and password fields, and username is dimmed and it has network service account. I write any password, for example 12345 and click start. After some time i see in console services.msc, that user profile service started. And it creates groups FIMSyncOperator, FIMSyncJoiners and FIMSyncBrowse, and some dcom objects, related to FIM.

    But it not solved the problem, because password, i entered, is not right, and it gives error in application event logs.

    I think, the service not working in standalone installation. Only when i install SP 2010 in Server Farm mode, i can config service, select domain account for it, and start it succesfully.

  5. Pingback: File Manager,File Size,File Catalog,File Analyzer,Disk Space,File Extensions,analysis software,Disk Storage

  6. Pingback: implantacion erp

  7. HelloThere says:

    I had the same problem, the FIMS didn’t want to start; in my case the database was on a different server as a named instance. The problem happened after I installed the ´12JUN-office2010-kb2598354-fullfile-x64-glb´ CU.
    I don’t know exactly what helped, but the following changes were done:
    – named pipes enabling on SQL server
    – granting rights to Network service on ´C:\Program Files\Microsoft Office Servers\14.0´
    – restart the server, restart services zillion times
    – recreated USP application (probably not necessary)

    The resolution was technically not much expected:
    1. open an MMC with the Groups
    2. go to the services: http://farmadmin/_admin/Server.aspx
    3. click the Start on the User Profile Synchronization Service
    4. now change to the MMC, then you will see the above mentioned FIMS groups
    5. add your farm admin account to the groups

    After this the groups kept visible, and now the synchronization service is running.

Leave a Reply

Your email address will not be published. Required fields are marked *